New member
Jun 26, 2014



The SONY ERICSSON logo screen stuck at start-up forever when I presed the power button-on.


Spec: Sony Satio U1i Black color. O/S Symbian NOT ANDROID !! firmware in Chinese language-Hong Kong/ Taiwan version. My phone can also switch to English as well when I need to....

A while ago, I deleted one of the useless game that came along with the satio U1, never played, so I wanted to "make-room" for memory storage. Then, when I turned on the phone the next day, it stuck at ( as I described / mentioned above).

I took it to a local shop for repair, they said they did the flashing for me and was able to repair my phone back in normal order, although all "stuff" were gone as they did the flashing.

But I had all backed-up, in fact, before the "accident" happened, I had the whole phone back-up, which including a big file about 800 MB +/- which I believed it is the firmware, although I could not open it using my computer.

2 weeks ago, I forgot to re-charge the battery and went dead. Next day I re-charged it for like 3 hours, SAME PROBLEM happen to me again-- Sony Ericsson Logo stuck forever.

As usual, I tried using PC companion Update & Repair both, did'nt help as expected.

Took it back to the same repair shop, but this time the technican no longer works there & the other guy said he tried but somehow he could'nt fix it. But he said it is NOT hardware problem.

Please provide address and phone # or private message should rules/ polices of this forum apply.